Page 1 of 1

Hibernated NTFS Partition

Posted: Fri Aug 19, 2016 3:55 am
by ByTheByte

Two separate clients have come to me with a windows 10 issue where the update caused a boot loop. As none of the recovery tools worked with the OS, I removed the drive, connected it to my Ubuntu machine and tried to mount.

Windows is hibernated, refused to mount!

Because I can't get into windows, Im unable to shut it down properly. nor can I mount the drive.

Any ideas?

I've tried
mount -t ntfs-3g -o remove_hiberfile /dev/sda5
But that didn't work. When I plug it into windows, it states the drive is incompatible and needs to be formatted before it will work. Of course that isn't what I want to do. I just want to get the files :)


Re: Hibernated NTFS Partition

Posted: Fri Aug 19, 2016 12:31 pm
by lcoughey
My first thought is, don't assume that the hard drive is healthy. Many times weird windows issues come to the surface because there is an underlying issue with the hard drive. So, here is my suggested approach.

1. Get a full sector-by-sector clone of the drive with ddrescue
> ddrescue [source] [destination] logfile
Source would be /dev/sda, based on what you supplied in your OP.
2. Set the original drive aside and use the clone to play with.

3. Scan the drive with a decent data recovery program like R-Studio

4. Save the files out to another known healthy drive

5. Confirm that the files are 100% there and 100% healthy

6. If the original drive mirrored without any errors, run a full test with a program like MHDD. If it passes the test, format, re-install and restore the recovered files. If the drive is bad, replace the drive, re-install and restore the recovered files.

If you run into any issues, whatsoever, feel free to ask more. We also can provide remote assistance, when it makes sense.